Megszűnik a php 5.6-os verziójának támogatása (php verzióváltás)

Több tárhelyszolgáltató elkezdte értesíteni az ügyfeleit, hogy 2018. december végével megszűnik a php 5.6-os verziójának támogatása, ezért ők sem fogják biztosítani nekik ezt a verziót.

2018 végén az alábbi volt a php verziók támogatottsági ideje:

2022 elején az alábbi volt a php verziók támogatottsági ideje:

Mi az a php?

Egy nyílt forráskódú programozási nyelv, amely a webszervereken fut, és a legtöbb dinamikus weboldal (pl.: WordPress oldalak) ezt használja a működéséhez. Az egyes php verziók pár évig “élnek”. Az élettartamuk a bevezetésből, használatból és az új verzió megjelenéséből, valamint a biztonsági frissítések végső határidejének meghatározásából áll.

Mit kell tenned a php verzióváltás kapcsán?

  1. Érdemes ellenőrizned (erre a phpinfo függvény tökéletes és egyszerű megoldás), hogy milyen php verziót használ a weboldalad szervere. Ha a tárhelyszolgáltatód már jelezte az átállás szükségességét, akkor nem kell ezzel foglalkoznod. Ha legalább 5.2-es WordPress-t használsz, akkor az admin felületen is ellenőrizheted az aktuális php verziót.
  2. Meg kell tudnod, hogy biztosítja-e a tárhelyszolgáltató egy újabb php verzió használatát. Jelenleg min. 7.1 vagy 7.2 verzióra van szükséged, de ha lehet, akkor inkább 7.4-es php verziót kell használni.
  3. Tesztelned kell a weboldaladat az új környezetben, és ha hibát észlelsz, javítanod kell a végleges átállás előtt. Ezt megteheted egy bővítménnyel is, de szükséges a manuális ellenőrzés is (tesztkörnyezet létrehozásával).
  4. Át kell térni az új php verzióra. Erre két fő lehetőséged van:

Php verzióváltás, 1. opció:

Egy kattintással át tudod állítani a használt php verziót a tárhelyszolgáltatásod admin felületén, pl. egy ilyen legördülő menüben való átállítással:

Php verzióváltás a Viacom Kft. szerverén
Php verzióváltás a Viacom Kft. szerverén

Php verzióváltás, 2. opció:

Ha cPaneles tárhelyed van, akkor itt tudod megtenni a váltást:

Lépj be, és keress rá a php-ra:

A MultiPHP Manager segítségével domainenként tudod állítani a php verziót: Előbb be kell jelölni a módosítani kívánt domaint, majd a PHP verziók közül kiválasztani azt, amire szükség van, és megnyomni az Alkalmazás gombot.

PHP verzióváltás domainenként
PHP verzióváltás domainenként

A PHP Selector segítségével az összes domain php verziója egyszerre módosítható:

PHP verzióváltás (minden domain)
PHP verzióváltás (minden domain)

Php verzióváltás, 3. opció:

Ha a fentiek alapján nem boldogulsz a feladattal, írj a tárhelyszolgáltatónak, hogy váltsa a át a php verzió 7.4-re. Ha fontos, hogy az oldalon biztos ne legyen gond, akkor egyeztess vele időpontot a váltásra vonatkozóan. Ekkor tudod gyorsan ellenőrizni a weboldalt, és szükség esetén kérni a visszaállítást.

Php verzióváltás, 4. opció:

Ha a fentiek közül egyik sem vezet eredményre, akkor másik szerverre kell költöztetni a weboldalt. Ez egy sima WordPress költöztetés feladat.

Miért jó a php verzióváltás?

  1. Biztonságosabb: A korábbi verziókban talált esetleges biztonsági rések befoltozásra kerülnek. Míg a régi php verziók egy idő után nem kapnak ilyen frissítést.
  2. Gyorsabb: A fejlesztők figyelnek arra, hogy mindig gyorsabbak legyenek az új verziók a korábbiaknál.
  3. Funkcionálisabb: A verzióváltással mindig több funkció érhető el, mint korábban.

Cikkértesítő

Ha nem szeretnél lemaradni az új cikkekről, akkor iratkozz fel az értesítőre!

Szólj hozzá!

WordPress segítséget keresel?

Kérj díjmentes árajánlatot!

Főbb szolgáltatásaim: weboldal/webáruház készítés, megújítás, fejlesztés, gyorsítás, karbantartás, hibajavítás, oktatás, stb.